forked from loafle/openapi-generator-original
24 lines
507 B
Nix
24 lines
507 B
Nix
{
|
|
description = "OpenAPI generator nix flake";
|
|
|
|
inputs.nixpkgs.url = "github:nixos/nixpkgs";
|
|
inputs.flake-utils.url = "github:numtide/flake-utils";
|
|
|
|
outputs = { self, nixpkgs, flake-utils, ... }:
|
|
flake-utils.lib.eachDefaultSystem (system:
|
|
let
|
|
pkgs = import nixpkgs { inherit system; };
|
|
in
|
|
{
|
|
devShells.default = pkgs.mkShell
|
|
{
|
|
buildInputs = with pkgs;[
|
|
jdk8
|
|
maven
|
|
];
|
|
};
|
|
}
|
|
);
|
|
}
|
|
|