mirror of
https://github.com/OpenAPITools/openapi-generator.git
synced 2025-05-12 04:30:51 +00:00
* Switch Poison to Jason * generate-samples.sh * Finalize Poison -> Jason switch * parse date-time values to Elixir DateTime * improve formatting in various places, so there's less changes by `mix format` later * fix Java version in flake.nix * Use List.delete/2 instead of Enum.reject/2 for performance reasons * mix format test/* * Install dialyxir and fix reported issues * Fix RequestBuilder.decode/2 hardcoded module name * Update docs * Revert changes to API spec (HTTP -> HTTPS) * Revert uneeded change to Elixir code generator * Use HTTP in Elixir tests HTTPS doesn't work for folks who setup petstore.swagger.io as described in docs/faq-contributing.md. --------- Co-authored-by: Wojciech Piekutowski <wojciech@piekutowski.net>
24 lines
508 B
Nix
24 lines
508 B
Nix
{
|
|
description = "OpenAPI generator nix flake";
|
|
|
|
inputs.nixpkgs.url = "github:nixos/nixpkgs";
|
|
inputs.flake-utils.url = "github:numtide/flake-utils";
|
|
|
|
outputs = { self, nixpkgs, flake-utils, ... }:
|
|
flake-utils.lib.eachDefaultSystem (system:
|
|
let
|
|
pkgs = import nixpkgs { inherit system; };
|
|
in
|
|
{
|
|
devShells.default = pkgs.mkShell
|
|
{
|
|
buildInputs = with pkgs;[
|
|
jdk11
|
|
maven
|
|
];
|
|
};
|
|
}
|
|
);
|
|
}
|
|
|